CMS「すぐ使えるCGI」の開発者がご質問にお答えします

 

(必要なモジュールが使用できません。(CGI))というエラーが出る。 (No. 705)

回答日: 2010-02-16
<< 掲示板一覧  >> 質問する

質問

画像付ウェブページ更新ツール 大容量版のadmin/admin.cgiにアクセスすると「(必要なモジュールが使用できません。(CGI))」というエラーが出ます。


以下表示されたエラー

エラー
処理の途中でエラーが起きました。
大変申し訳ありませんが、時間が経ってから再度作業して下さい。

このエラーが続く時は、管理者に連絡して下さい。CGI 設定中の場合、設定を確認して下さい。

(必要なモジュールが使用できません。(CGI))

[ オンラインサポート情報検索 ]
投稿日時: 2010-02-15 19:14

回答

■エラーの原因

このエラーは、お使いのサーバに必要な Perl モジュール(プログラムの部品)がインストールされていないために表示されます。
必要なモジュールがインストールされていないサーバでは、「すぐ使えるCGI」をお使いになれません。


■対応方法

○管理者にリクエストができる場合

サーバ管理者にサーバ環境に関するリクエストができる場合、「Perl のモジュール CGI.pm を使いたい」と相談してみて下さい。


○それ以外

「Perl の標準モジュール」が利用可能なサーバでのご利用をご検討下さい。
ユーザのオリジナル CGI を許可している有料のサービスでは大抵の場合利用できます。

例えば以下のレンタルサーバサービスでは稼働実績があります。

さくらインターネット: http://www.sakura.ne.jp/
CPI: http://www.cpi.ad.jp/



回答日: 2010-02-16

さらに詳しく