小規模Webサイト向け CMS 「すぐ使えるCGI」のサポート情報

Perl のバージョンが 5.10 になりました。CGI の文字コードを UTF-8 にする必要がありますか?

最終更新日: 2013-04-25

問題

Webサーバが変更され、Perlのバージョンが 5.10.x にバージョンアップしました。
CGIの文字コードは UTF-8 でなければいけないとサーバ会社(管理者)言われたのですが、「すぐ使えるCGI」の文字コードも変更する必要がありますか?

Perl のバージョンアップと対応文字コードについて

Ver. 3.0 以上の「すぐ使えるCGI」であればどの文字コードでも Perl 5.10.x に対応していますので、Perl のバージョンアップに合わせて「すぐ使えるCGI」の文字コードを変更する必要はありません。

Perl のバージョンの変更に伴い必要になる「すぐ使えるCGI」のバージョンアップ

ご利用中の「すぐ使えるCGI」のバージョンが 2.x 以下の場合は、文字コードに関わらず Perl 5.10 以上では動作しません。「すぐ使えるCGI」の方もバージョンアップを行って下さい。

「すぐ使えるCGI」のバージョンアップの方法

各製品によってデータの引継ぎ方法やバージョンアップ方法が異なりますので、最新バージョンに含まれている「バージョンアップの方法」をご参照下さい。

関連リンク

さらに詳しく