CMS「すぐ使えるCGI」の開発者がご質問にお答えします

 

CLEditorが Win8+IE10 で動きません (続き) (No. 1566)

回答日: 2014-10-23
<< 掲示板一覧  >> 質問する

質問

ご回答、ありがとうございます。

バージョンについてですが、1.4.4でも1.4.5でも、ウィンドウをリサイズするとブラウザが落ちるようです。

こちらではWindows8+IE11の組み合わせ以外ではブラウザが落ちることはありませんでした。

Windows8.1では落ちません。

何か情報をお持ちでしたらご教授願えますでしょうか?

よろしくお願いいたします。
投稿日時: 2014-10-22 16:31

回答

※ このご質問は No. 1565 http://sugutsukaeru.jp/bbs/1565/ の続きです。

「すぐ使えるCGI」のご利用ありがとうございます。

■問題の起こる環境についての確認
ご質問の件につきまして再三の確認で恐縮ですが、「すぐ使えるCGI」のサイトでは CLEditor の 1.4.5 をベースにしたエディタは提供しておりませんので、問題は、1.4.4 についても 1.4.5 についてもお客様ご自身でダウンロードされた本家 CLEditor で起こると言う認識でよろしいでしょうか?

■考えられる原因
現在弊社では問題を確認できる環境がありませんので、考えられる可能性だけご回答致します。

CLEditor のプログラムにはブラウザを判別して動作を変更する処理が含まれています。これには、1.4.4 から含まれているものと、1.4.5 だけに含まれているものがあります。上記の通りこちらでは動作を検証できる環境がありませんが、コードを読んだ限りでは、このブラウザの判別が細かい IE 環境まではうまく対応していない点がありそうです。このため、バージョンに適応していない JavaScript コードが実行されてこの影響でブラウザが落ちるのではないかと思います。

以上でお答えになりますでしょうか?
なお、これ以上の一般的な技術サポートはこの掲示板ではご対応できませんので何卒ご了承下さい。

■「すぐ使えるCGI」使用に際する問題の場合
また、「すぐ使えるCGI」からダウンロードできる CLEditor で同じ問題が起こる場合、対応バージョンをすぐにご提供する事は難しいですので、恐縮ですが動作可能なブラウザで編集作業を頂けますようお願い致します。
回答日: 2014-10-23

さらに詳しく